Skip to main content
VulnerabilityPublished

CVE-2026-123990: DataEase · Injection

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123990· Medium 6.9

Public exploit available · CVSS 6.9 Medium.

Data as of 7 Nov 2026, 19:34 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.06.9
CNA (VulDB)CVSS 3.17.3
CNA (VulDB)CVSS 3.07.3
CNA (VulDB)CVSS 2.07.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
DataEaseAffected
  • 2.10.0 – 3.1.0
30 affected builds
Fixed in–
GitHubdataease/dataeasepkg:github/dataease/dataeaseOther threatsAffected
  • 2.10.0 – 3.1.0
30 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected DataEase installations to version 3.2.0 or later, where the vulnerability is fixed. The vendor's fix includes validation of the compound operator and use of fixed AND/OR keywords to prevent SQL injection. No other mitigation is indicated by the vendor advisory.

Description

A SQL injection vulnerability exists in DataEase versions up to 2.10.27 and 3.1.0 in the ExtWhere2Str.extWhere2sqlOjb function of the Chart Data Handler component. This flaw allows remote attackers to manipulate the operator argument, leading to SQL injection. The vulnerability has been publicly disclosed and exploit code may be available. Upgrading to version 3.2.0 addresses the issue by validating the compound operator and using fixed AND/OR keywords instead of concatenating user input into SQL queries.

References

Community reviews

Loading reviews…