CVE-2026-82231: Apache bRPC (version · Thrift Client
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.18.0 soon.
Data as of 30 Oct 2026, 17:17 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 1.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache bRPC and apache/brpc to 1.18.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache bRPCapache/brpc | Affected
| Fixed in
|
GitHubapache/brpcpkg:github/apache/brpcOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache bRPC to version 1.18.0, which contains the official fix for this vulnerability. Alternatively, apply the patch available at https://github.com/apache/brpc/pull/3500. Since the vulnerability requires the WITH_THRIFT build option (which is off by default), disabling this option if not needed can also mitigate exposure.
Description
Apache bRPC versions prior to 1.18.0, when built with the WITH_THRIFT option enabled, contain a vulnerability in the Thrift client component. A malicious or malformed server response with an improperly structured T_EXCEPTION can cause the client to throw uncaught exceptions, leading to process termination and disruption of all ongoing RPC calls. This vulnerability affects the client response path and assumes the server peer is untrusted. The issue is fixed in version 1.18.0.