CVE-2025-5459: A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary
Source GCVE Database
Not known to be exploited · CVSS 8.6 High · fixed in 2023.8.4 : patch Puppet Enterprise soon.
Data as of 26 Oct 2026, 11:07 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2023.8.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PerforcePuppet Enterprise | Affected
| Fixed in– |
AI-suggested
Upgrade Puppet Enterprise to version 2023.8.4 or later, or 2025.4.0 or later, where this vulnerability has been resolved. No other mitigations or temporary fixes are indicated. Patch status is confirmed by the version information provided.
Description
CVE-2025-5459 is a high-severity command injection vulnerability in Puppet Enterprise. A user with specific node group editing permissions can exploit a specially crafted class parameter to execute commands as root on the primary host. This affects Puppet Enterprise versions from 2018.1.8 through 2023.8.3 and 2025.3. The issue has been resolved in versions 2023.8.4 and 2025.4.0.