Skip to main content
VulnerabilityPublished Updated

CVE-2026-110810: ggml-org whisper.cpp

Affects whisper.cppSource GCVE Database

0
Authoritative record:CVE-2026-110810· Low 2.4

Public exploit available · CVSS 2.4 Low · fixed in 1.9.5 : patch whisper.cpp as a priority.

Data as of 28 Oct 2026, 23:58 UTC

CVSS 4.0 base score
2.4Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.9.5
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10whisper.cpppkg:deb/ubuntu/whisper.cpp?arch=source&distro=stonkingOther threatsAffected
  • 1.8.3+dfsg-2 – 1.9.2+dfsg-1
6 affected builds
Fixed in–
Ubuntu 26.04 LTSwhisper.cpppkg:deb/ubuntu/whisper.cpp?arch=source&distro=resoluteOther threatsAffected
  • =1.8.3+dfsg-2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to ggml-org whisper.cpp version 1.9.5 or later, which contains the official fix for this vulnerability. The vendor has released this patch promptly, and applying it fully mitigates the issue.

Description

A vulnerability in the whisper_model_load function of the src/whisper.cpp component in ggml-org whisper.cpp up to version 1.9.4 allows a local attacker to cause an out-of-bounds read by manipulating the argument ttype. This issue has a low severity score and does not impact confidentiality or integrity but may affect availability. A fixed version 1.9.5 has been released to address this vulnerability.

References

Community reviews

Loading reviews…