Skip to main content
VulnerabilityPublished Updated

CVE-2026-3731: libssh

Affects libsshSource GCVE Database

0
Authoritative record:CVE-2026-3731· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium · fixed in 0.6.3-4.3ubuntu0.6+esm5 : update libssh when convenient.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.3-4.3ubuntu0.6+esm5, 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm7, 0.9.3-2ubuntu2.5+esm4 +4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=resoluteOther threatsAffected
  • <0.11.3-1ubuntu2
Fixed in
  • 0.11.3-1ubuntu2
Ubuntu 25.10libsshpkg:deb/ubuntu/libssh?arch=source&distro=questingOther threatsAffected
  • <0.11.2-1ubuntu0.3
Fixed in
  • 0.11.2-1ubuntu0.3
Ubuntu 24.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=nobleOther threatsAffected
  • <0.10.6-2ubuntu0.4
Fixed in
  • 0.10.6-2ubuntu0.4
Ubuntu 22.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=jammyOther threatsAffected
  • <0.9.6-2ubuntu0.22.04.7
Fixed in
  • 0.9.6-2ubuntu0.22.04.7
Ubuntu Pro 20.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/focalOther threatsAffected
  • <0.9.3-2ubuntu2.5+esm4
Fixed in
  • 0.9.3-2ubuntu2.5+esm4
Ubuntu Pro 18.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <0.8.0~20170825.94fa1e38-1ubuntu0.7+esm7
Fixed in
  • 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A weakness has been identified in libssh up to 0.11.3. The impacted element is the function sftp_extensions_get_name/sftp_extensions_get_data of the file src/sftp.c of the component SFTP Extension Name Handler. Executing a manipulation of the argument idx can lead to out-of-bounds read. The attack may be performed from remote. Upgrading to version 0.11.4 and 0.12.0 is sufficient to resolve this issue. This patch is called 855a0853ad3abd4a6cd85ce06fce6d8d4c7a0b60. You should upgrade the affected component.

References

Community reviews

Loading reviews…