Skip to main content
VulnerabilityPublished Updated

CVE-2026-54279: aiohttp · Host-Only Cookies Become Domain Cookies After CookieJar Persistence

Affects parsedmarcSource GCVE Database

0
Compare
Authoritative record:CVE-2026-54279· Low 1.3

Not known to be exploited · CVSS 1.3 Low : upgrade to 10.0.3_1 or 9.9.0 when convenient.

Data as of 4 Nov 2026, 06:59 UTC

CVSS 4.0 base score
1.3Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 10.0.3_1, 9.9.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade parsedmarc to 10.0.3_1 or 9.9.0.

Affected software

ProductAffectedFixed in
Homebrewparsedmarcpkg:brew/parsedmarcOther threatsAffected
  • >=8.11.0 <9.9.0
  • >=9.11.0 <10.0.3_1
Fixed in
  • 9.9.0
  • 10.0.3_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in aiohttp versions 9.9.0 and 10.0.3_1. Users should upgrade to one of these fixed versions to remediate the vulnerability. No additional mitigation steps are required beyond applying the official fix.

Description

A vulnerability in aiohttp causes host-only cookies saved and later restored via CookieJar persistence to lose their host-only attribute. This results in cookies being sent to subdomains that should not receive them, potentially exposing sensitive session data. The issue affects versions >=8.11.0 <9.9.0 and >=9.11.0 <10.0.3_1 and has been fixed in versions 9.9.0 and 10.0.3_1. The vulnerability has a high severity rating with a CVSS score of 7.5.

References

Community reviews

Loading reviews…