Skip to main content
VulnerabilityPublished

CVE-2026-27975: aj · Ajenti has potential Remote Code Execution

Affects ajSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.2.13 as a priority.

Data as of 27 Oct 2026, 14:42 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.2.13
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade aj to 2.2.13.

Affected software

ProductAffectedFixed in
PyPIajAffected
  • <2.2.13
Fixed in
  • 2.2.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Ajenti to version 2.2.13 or later, where this vulnerability is fixed. Applying this official patch is the recommended and effective mitigation.

Description

Ajenti versions prior to 2.2.13 contain a critical remote code execution vulnerability (CVE-2026-27975) that allows unauthenticated users to execute arbitrary code on the affected server. This vulnerability has a CVSS score of 9.8, indicating a high severity with network attack vector, no privileges required, and no user interaction needed. The issue is fixed in version 2.2.13, and users are strongly advised to upgrade to this version promptly to mitigate the risk.

References

Community reviews

Loading reviews…