CVE-2025-0993: Allocation of Resources Without Limits or Throttling in GitLab
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 18.0.1 or 17.11.3 soon.
Data as of 26 Oct 2026, 14:05 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.0.1, 17.11.3
Exploitation evidence
Disclosed: evidence found.
CVE published 26 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 18.0.1 or 17.11.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading to GitLab versions 17.10.7 or later, 17.11.3 or later, and 18.0.1 or later. These versions include fixes that implement proper resource limits and throttling to prevent exhaustion attacks.
Description
A resource allocation vulnerability exists in GitLab CE/EE versions before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. An authenticated attacker could exploit this issue to exhaust server resources, causing a denial of service condition. Patches addressing this vulnerability are available.