CVE-2026-58663: Authentication Bypass Vulnerability Exists
Source GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.0.11 as a priority.
Data as of 30 Oct 2026, 21:05 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 9.8 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.11
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache IoTDB and org.apache.iotdb/iotdb to 2.0.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache IoTDB | Affected
| Fixed in
|
Mavenorg.apache.iotdb/iotdbpkg:maven/org.apache.iotdb/iotdbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache IoTDB to version 2.0.11, which contains the official fix for this authentication bypass vulnerability. No other mitigation is indicated by the vendor advisory.
Description
An authentication bypass vulnerability exists in Apache IoTDB's Thrift RPC service affecting versions from 2.0.0 up to but not including 2.0.11. This flaw allows unauthenticated attackers to bypass authentication controls, potentially leading to full compromise of confidentiality, integrity, and availability. The issue is fixed in version 2.0.11, and users are strongly advised to upgrade to this version to mitigate the risk.