Skip to main content
VulnerabilityPublished Updated

CVE-2026-61477: libvirt's virtual network driver · Injection Vulnerability Was Found

Affects libvirtSource GCVE Database

0
Compare
Authoritative record:CVE-2026-61477· Low 2.3

Not known to be exploited · CVSS 2.3 Low · fixed in 1.3.1-1ubuntu10.31+esm1 : update libvirt when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.12.3
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.1-1ubuntu10.31+esm1, 4.0.0-1ubuntu8.21+esm1, 6.0.0-0ubuntu8.20+esm1 +3
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlibvirtpkg:deb/ubuntu/libvirt?arch=source&distro=resoluteOther threatsAffected
  • <12.0.0-1ubuntu5.3
Fixed in
  • 12.0.0-1ubuntu5.3
Ubuntu 26.04 LTSlibvirt-hwepkg:deb/ubuntu/libvirt-hwe?arch=source&distro=resoluteOther threatsAffected
  • 12.0.0-1ubuntu5 – 12.0.0-1ubuntu5.3
4 affected builds
Fixed in–
Ubuntu 24.04 LTSlibvirtpkg:deb/ubuntu/libvirt?arch=source&distro=nobleOther threatsAffected
  • <10.0.0-2ubuntu8.16
Fixed in
  • 10.0.0-2ubuntu8.16
Ubuntu 22.04 LTSlibvirtpkg:deb/ubuntu/libvirt?arch=source&distro=jammyOther threatsAffected
  • <8.0.0-1ubuntu7.19
Fixed in
  • 8.0.0-1ubuntu7.19
Ubuntu Pro 20.04 LTSlibvirtpkg:deb/ubuntu/libvirt?arch=source&distro=esm-infra/focalOther threatsAffected
  • <6.0.0-0ubuntu8.20+esm1
Fixed in
  • 6.0.0-0ubuntu8.20+esm1
Ubuntu Pro 18.04 LTSlibvirtpkg:deb/ubuntu/libvirt?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <4.0.0-1ubuntu8.21+esm1
Fixed in
  • 4.0.0-1ubuntu8.21+esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available to fix this vulnerability. Users should apply the official updates provided by their vendor or distribution to remediate this issue. The Red Hat advisory notes that no alternative mitigations currently meet their criteria for ease of use and applicability, so patching is the recommended course of action.

Description

An injection vulnerability exists in libvirt's virtual network driver due to improper handling of newline characters in DNS TXT and SRV record attributes. This flaw allows users with permission to define virtual networks to inject arbitrary dnsmasq configuration directives, potentially leading to arbitrary command execution as root. The vulnerability has a medium severity score and affects multiple versions of libvirt. A patch is available to address this issue.

References

Community reviews

Loading reviews…