Skip to main content
VulnerabilityPublished

CVE-2026-6664: network packet parsing code · Integer Overflow

Source GCVE Database

0
Authoritative record:CVE-2026-6664· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.25.2 soon.

Data as of 27 Oct 2026, 02:43 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.25.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PgBouncer to 1.25.2.

Affected software

ProductAffectedFixed in
PgBouncerAffected
  • <1.25.2
Fixed in
  • 1.25.2

AI-suggested

Upgrade PgBouncer to version 1.25.2 or later, where this integer overflow vulnerability has been fixed. No other mitigation or temporary workaround is indicated in the available data.

Description

CVE-2026-6664 is an integer overflow vulnerability in the network packet parsing code of PgBouncer versions before 1.25.2. This flaw allows an unauthenticated remote attacker to bypass a boundary check by sending a malformed SCRAM authentication packet, causing PgBouncer to crash.

References

Community reviews

Loading reviews…