Skip to main content
VulnerabilityPublished Updated

CVE-2026-11850: MIT krb5 · Integer Underflow Vulnerability Was Found

Affects krb5Source GCVE Database

0
Authoritative record:CVE-2026-11850· Medium 5.0

Not known to be exploited · CVSS 5.0 Medium · fixed in 1.19.2-2ubuntu0.8 : update krb5 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
5.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.19.2-2ubuntu0.8, 1.20.1-6ubuntu2.7, 1.22.1-2ubuntu4.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu krb5 to 1.19.2-2ubuntu0.8 (package) or 1.20.1-6ubuntu2.7 (package) or 1.22.1-2ubuntu4.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSkrb5pkg:deb/ubuntu/krb5?arch=source&distro=resoluteOther threatsAffected
  • <1.22.1-2ubuntu4.1
Fixed in
  • 1.22.1-2ubuntu4.1
Ubuntu 25.10krb5pkg:deb/ubuntu/krb5?arch=source&distro=questingOther threatsAffected
  • =1.21.3-4ubuntu2
  • =1.21.3-5ubuntu1
  • =1.21.3-5ubuntu2
Fixed in–
Ubuntu 24.04 LTSkrb5pkg:deb/ubuntu/krb5?arch=source&distro=nobleOther threatsAffected
  • <1.20.1-6ubuntu2.7
Fixed in
  • 1.20.1-6ubuntu2.7
Ubuntu 22.04 LTSkrb5pkg:deb/ubuntu/krb5?arch=source&distro=jammyOther threatsAffected
  • <1.19.2-2ubuntu0.8
Fixed in
  • 1.19.2-2ubuntu0.8
Ubuntu 20.04 LTSkrb5pkg:deb/ubuntu/krb5?arch=source&distro=focalOther threatsAffected
  • 1.17-6 – 1.17-6ubuntu4.11
12 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSkrb5pkg:deb/ubuntu/krb5?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.15.1-2 – 1.16-2ubuntu0.4+esm5
12 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

An integer underflow vulnerability was found in MIT krb5 in the berval2tl_data() function in plugins/kdb/ldap/libkdb_ldap/ldap_principal2.c. The function performs an unsigned subtraction (bv_len - 2) without a prior bounds check. When bv_len is 0 or 1, the subtraction wraps to a large value which is then truncated to uint16_t, yielding 0xFFFE (65534) or 0xFFFF (65535). The subsequent malloc succeeds and memcpy reads up to 65534 bytes from a 0-1 byte buffer, resulting in a heap out-of-bounds read. The attack vector involves a malicious or compromised LDAP KDB backend returning a krbExtraData attribute with bv_len < 2, triggering the underflow when the KDC or kadmind reads principal data.

References

Community reviews

Loading reviews…