Skip to main content
VulnerabilityPublished Updated

CVE-2024-33452: OpenResty lua-nginx-module v.0.10.26

Affects openrestySource GCVE Database

0

Not known to be exploited : upgrade to 1.25.3 soon.

Data as of 26 Oct 2026, 09:15 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.25.3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade openresty to 1.25.3.

Affected software

ProductAffectedFixed in
Bitnamiopenrestypkg:bitnami/openrestyOther threatsAffected
  • <1.25.3
Fixed in
  • 1.25.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade OpenResty lua-nginx-module to version 1.25.3 or later to remediate the issue. No additional mitigation steps are indicated in the provided information.

Description

OpenResty lua-nginx-module versions 0.10.26 and earlier contain a vulnerability that allows a remote attacker to perform HTTP request smuggling using a crafted HEAD request. This issue affects versions prior to 1.25.3. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…