Skip to main content
VulnerabilityPublished Updated

CVE-2026-78807: wpa_supplicant all · CWE-346

Affects wpaSource GCVE Database

0
Authoritative record:CVE-2026-78807· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 2.12 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.08% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.12
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/wpa_supplicant package to 2.12.

Affected software

ProductAffectedFixed in
Debiandebian/wpa_supplicantpkg:deb/debian/wpa_supplicantOther threatsAffected
  • <2.12
Fixed in
  • 2.12
Ubuntu Pro 14.04 LTSwpapkg:deb/ubuntu/wpa?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 1.0-3ubuntu2 – 2.1-0ubuntu1.7+esm5
16 affected builds
Fixed in–
Ubuntu 16.04 LTSwpapkg:deb/ubuntu/wpa?arch=source&distro=xenialOther threatsAffected
  • 2.4-0ubuntu3 – 2.4-0ubuntu6.8+esm1
12 affected builds
Fixed in–
Ubuntu 18.04 LTSwpapkg:deb/ubuntu/wpa?arch=source&distro=bionicOther threatsAffected
  • 2:2.4-1.1ubuntu1 – 2.4-0ubuntu10
13 affected builds
Fixed in–
Ubuntu 20.04 LTSwpapkg:deb/ubuntu/wpa?arch=source&distro=focalOther threatsAffected
  • 2:2.9-1ubuntu2 – 2:2.9-1ubuntu4.6
8 affected builds
Fixed in–
Ubuntu 22.04 LTSwpapkg:deb/ubuntu/wpa?arch=source&distro=jammyOther threatsAffected
  • 2:2.9.0-21build1 – 2:2.10-6ubuntu2.4
11 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, limit local access to trusted users and environments.

Description

A vulnerability in wpa_supplicant versions prior to 2.12 allows a local attacker to bypass proper network context and AKMP matching for PMKSA caching due to missing validation in the driver-based PMKSA selection path. This issue affects multiple SUSE and Ubuntu builds across various architectures. The vulnerability has a CVSS score of 7.1, indicating medium severity.

References

Community reviews

Loading reviews…