Skip to main content
VulnerabilityPublished

CVE-2025-27918: AnyDesk · Integer Overflow

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-27918· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 9.0.0 : patch AnyDesk as a priority.

Data as of 4 Nov 2026, 18:48 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Affects
AnyDesk before 9.0.0
Patch
Available – fixed in 9.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

AI-suggested

Users should upgrade AnyDesk to version 9.0.0 or later, where this vulnerability is fixed. Until patched, avoid exposing AnyDesk services to untrusted networks to reduce risk.

Description

A critical vulnerability (CVE-2025-27918) exists in AnyDesk versions before 9.0.0. It involves an integer overflow leading to a heap-based buffer overflow triggered by specially crafted UDP packets during processing of an Identity user image in the Discovery feature or when establishing connections between clients.

References

Community reviews

Loading reviews…