Skip to main content
VulnerabilityPublished

CVE-2026-43505: Prosody · CWE-420

Source GCVE Database

0
Authoritative record:CVE-2026-43505· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 13.0.5 : update Prosody when convenient.

Data as of 27 Oct 2026, 00:42 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Affects
Prosody before 0.12.6
Patch
Available – fixed in 13.0.5, 0.12.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

Since fixed versions are identified as 0.12.6 and 13.0.5, upgrading Prosody to at least these versions is recommended to mitigate the vulnerability. If upgrading is not immediately possible, disabling the mod_proxy65 module can prevent exploitation.

Description

A vulnerability in Prosody versions before 0.12.6 and from 1.0.0 through 13.0.0 before 13.0.5 affects the mod_proxy65 module. The issue arises from improper access control handling during activation, allowing unauthenticated traffic to be relayed through the server.

References

Community reviews

Loading reviews…