NTPsec · Out-of-bounds Read
Affects ntpsecSource GCVE Database
Not known to be exploited · CVSS 3.7 Low : upgrade to 1.2.4 when convenient.
Data as of 3 Nov 2026, 16:15 UTC
Thin evidence
One scorer or none| CNA (GitLab) | CVSS 3.1 | 3.7 |
|---|
- Affects
- NTPsec before 1.2.4
- Patch
- Available – fixed in 1.2.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade ntpsec/ntpsec to 1.2.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubntpsec/ntpsecpkg:github/ntpsec/ntpsecOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to NTPsec version 1.2.4 or later where this vulnerability is fixed. No other mitigation or temporary workaround is indicated. Patch status is not explicitly confirmed in the input, but the fixed version is stated as 1.2.4, so upgrading to this version or later resolves the issue.
Description
NTPsec versions before 1.2.4 contain an out-of-bounds read vulnerability in the NTS-KE client response parser. This flaw allows a malicious NTS-KE server to read the client's stack memory, including pointers that can defeat ASLR. The client then sends these pointers in cleartext as NTS cookies, due to an NTS-KE record declaring a length larger than the actual data received.