Skip to main content
VulnerabilityPublished Updated

CVE-2025-69228: Ansible · AIOHTTP vulnerable to denial of service through large payloads

Affects ansibleSource GCVE Database

0
Compare
Authoritative record:CVE-2025-69228· Medium 6.6

Not known to be exploited · CVSS 6.6 Medium : upgrade to 14.3.0 when convenient.

Data as of 30 Oct 2026, 07:30 UTC

CVSS 4.0 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 14.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade ansible to 14.3.0.

Affected software

ProductAffectedFixed in
Homebrewansiblepkg:brew/ansibleOther threatsAffected
  • <14.3.0
Fixed in
  • 14.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

### Summary A request can be crafted in such a way that an aiohttp server's memory fills up uncontrollably during processing. ### Impact If an application includes a handler that uses the `Request.post()` method, an attacker may be able to freeze the server by exhausting the memory. ----- Patch: https://github.com/aio-libs/aiohttp/commit/b7dbd35375aedbcd712cbae8ad513d56d11cce60

References

Community reviews

Loading reviews…