Skip to main content
VulnerabilityPublished Updated

CVE-2026-11332: ansible-core · Argument injection in ansible-galaxy role install leads to arbitrary code execution

Affects bbotSource GCVE Database

0
Compare
Authoritative record:CVE-2026-11332· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 3.0.0 soon.

Data as of 30 Oct 2026, 07:30 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.0.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade bbot to 3.0.0.

Affected software

ProductAffectedFixed in
Homebrewbbotpkg:brew/bbotOther threatsAffected
  • >=1.0.5.1665 <3.0.0
Fixed in
  • 3.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A flaw was found in ansible-core. The ansible-galaxy role install command processes dependency specifications from a role's meta/requirements.yml file. Due to improper neutralization of argument delimiters, a malicious role author can inject arbitrary git configuration flags through the src field. This allows arbitrary code execution on the machine of a user who installs the role via ansible-galaxy role install.

References

Community reviews

Loading reviews…