Skip to main content
VulnerabilityPublished Updated

CVE-2024-9902: ansible-core Incorrect Authorization vulnerability

Affects ansible-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2024-9902· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.14.18rc1 when convenient.

Data as of 31 Oct 2026, 01:26 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.14.18rc1, 2.15.13rc1, 2.16.13rc1 +2
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PyPIansible-coreAffected
  • <2.14.18rc1
Fixed in
  • 2.14.18rc1
PyPIansible-coreAffected
  • >=2.15.0b1 <2.15.13rc1
Fixed in
  • 2.15.13rc1
PyPIansible-coreAffected
  • >=2.16.0b1 <2.16.13rc1
Fixed in
  • 2.16.13rc1
PyPIansible-coreAffected
  • >=2.17.0b1 <2.17.6rc1
Fixed in
  • 2.17.6rc1
PyPIansible-coreAffected
  • >=2.18.0b1 <2.18.0rc2
Fixed in
  • 2.18.0rc2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches provided in ansible-core versions 2.14.18rc1, 2.15.13rc1, 2.16.13rc1, 2.17.6rc1, or 2.18.0rc2 or later. The vendor advisory confirms that these updates fix the vulnerability. No additional mitigation steps are indicated beyond updating to a fixed version.

Description

CVE-2024-9902 is a vulnerability in the ansible-core user module that allows an unprivileged user to create or replace any file on the system path and take ownership when a privileged user runs the user module against the unprivileged user's home directory. This occurs if the unprivileged user has traversal permissions on the directory containing the target file, enabling them to control the file contents as its owner.

References

Community reviews

Loading reviews…