CVE-2026-119197: Ansible@9 · pyasn1 has quadratic-complexity denial of service in binary REAL decoding
Affects ansible@9Source GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 0.6.5 : patch ansible@9 soon.
Data as of 31 Oct 2026, 17:21 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 0.6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewansible@9pkg:brew/ansible%409Other threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade pyasn1 to version 0.6.5 or later, where the vulnerability is fixed. Until upgrading, applications should reject or strictly limit ASN.1 input containing REAL values, especially large mantissas, before decoding with pyasn1. The appropriate input size limits depend on the application's CPU availability and request volume.
Description
pyasn1 versions up to 0.6.4 contain a denial of service vulnerability due to quadratic complexity in decoding binary-encoded ASN.1 REAL values with large mantissas. This causes excessive CPU consumption during decoding, potentially exhausting CPU resources. The issue affects BER, CER, and DER decoders that use the vulnerable RealPayloadDecoder. The vulnerability is fixed in pyasn1 version 0.6.5.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-mm57-4v3p-rchx (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119197 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/ce3ec3390784780a530047e0e77be5ff457636a4 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)