Skip to main content
VulnerabilityPublished Updated

CVE-2024-25141: Apache airflow providers mongo · Improper Certificate Validation in apache airflow mongo hook

Affects apache-airflow-providers-mongoSource GCVE Database

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.0.0 as a priority.

Data as of 26 Oct 2026, 22:27 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade apache-airflow-providers-mongo to 4.0.0.

Affected software

ProductAffectedFixed in
PyPIapache-airflow-providers-mongoAffected
  • <4.0.0
Fixed in
  • 4.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated. This was unexpected and undocumented. Users are recommended to upgrade to version 4.0.0, which fixes this issue.

References

Community reviews

Loading reviews…