CVE-2025-62503: Apache Airflow's create action can upsert existing Pools/Connections/Variables
Affects apache-airflowSource GCVE Database
Not known to be exploited · CVSS 4.6 Medium : upgrade to 3.1.1 when convenient.
Data as of 29 Oct 2026, 23:13 UTC
- Patch
- Available – fixed in 3.1.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade apache-airflow to 3.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIapache-airflow | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Airflow to version 3.1.1 or later, where this vulnerability is fixed. Since a patch is available and the issue is resolved in the fixed version, applying the official update is the recommended mitigation.
Description
Apache Airflow versions 3.0.0 up to but not including 3.1.1 contain a vulnerability where users with CREATE privileges but without UPDATE privileges on Pools, Connections, or Variables can update existing records by using the bulk create API with the overwrite action. This issue allows privilege escalation within the application data management. The vulnerability has a medium severity score of 4.6 and was fixed in version 3.1.1.