Skip to main content
VulnerabilityPublished

CVE-2026-111108: Apache Kafka's code-generated protocol readers pre-size an array's collection from the element count

Source GCVE Database

0
Authoritative record:CVE-2026-111108· High

Not known to be exploited · fixed in 4.2.2 : patch Apache Kafka soon.

Data as of 28 Oct 2026, 19:58 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 4.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Kafkaorg.apache.kafka:kafkaAffected
  • >=3.3.0 <=4.1.2
  • >=4.2.0 <=4.2.1
  • >=4.3.0 <=4.3.1
Fixed in–
MavenApache Software Foundation/org.apache.kafka:kafkapkg:maven/Apache Software Foundation/org.apache.kafka:kafkaOther threatsAffected
  • >=3.3.0 <=4.1.2
  • >=4.2.0 <=4.2.1
  • >=4.3.0 <=4.3.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Kafka to versions 4.2.2, 4.3.2, or 4.4.0 where the vulnerability is fixed. Until upgrading, reduce exposure by lowering the socket.request.max.bytes configuration and restricting network access to broker listeners. These interim measures reduce but do not eliminate the risk. The vendor advisory confirms the fix and recommends upgrading as the primary mitigation.

Description

Apache Kafka's code-generated protocol readers pre-allocate array collections based on a declared element count that is only loosely validated against the request buffer size. This can lead to excessive heap allocation before elements are read, enabling an attacker to cause an OutOfMemoryError and crash the broker. The vulnerability affects all Kafka API types with array fields and occurs before authorization checks, allowing unauthenticated attackers on unauthenticated listeners to exploit it. Fixed in Apache Kafka versions 4.2.2, 4.3.2, and 4.4.0 by capping pre-allocation and rejecting excessively large array lengths.

References

Community reviews

Loading reviews…