Skip to main content
VulnerabilityPublished Updated

CVE-2026-44825: Enabling BasicAuth using bin/solr CLI configures additional insecure users

Affects solrSource GCVE Database

0
Compare
Authoritative record:CVE-2026-44825· High 8.1

Not known to be exploited · public detection template (Nuclei) · CVSS 8.1 High : upgrade to 10.1.0 soon.

Data as of 30 Oct 2026, 16:06 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 10.1.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade solr to 10.1.0.

Affected software

ProductAffectedFixed in
Bitnamisolrpkg:bitnami/solrOther threatsAffected
  • >=9.4.0 <10.1.0
Fixed in
  • 10.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Solr to version 10.1.0 or later, where this vulnerability is fixed. As an immediate workaround without upgrading, delete the template users (superadmin, admin, search, index) from the security.json file or change their passwords to strong, unique values. Clusters that did not use the bin/solr auth enable tool to bootstrap BasicAuth or have already changed the default passwords are not affected.

Description

Apache Solr versions 9.4.0 through 9.10.1 and 10.0.0 have a vulnerability in the Basic Authentication setup tool (bin/solr auth enable) that creates additional default users with hardcoded credentials. These default users (superadmin, admin, search, index) are installed silently alongside the user-specified account, allowing a remote attacker to gain full administrative access if these credentials are not changed. Clusters not using the setup tool or those that have changed the default passwords are not affected. The issue is fixed in versions 10.1.0 and later.

References

Community reviews

Loading reviews…