Skip to main content
VulnerabilityPublished

CVE-2026-101356: Apache Tomcat · HTTP/2 request/response mix-up after error during async processing

Affects tomcatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-101356· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 11.0.27 : patch tomcat as a priority.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.27, 10.1.61, 9.0.123
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade tomcat to 11.0.27, 10.1.61 or 9.0.123.

Affected software

ProductAffectedFixed in
Bitnamitomcatpkg:bitnami/tomcatOther threatsAffected
  • >=9.0.118 <9.0.123
  • >=10.1.55 <10.1.61
  • >=11.0.22 <11.0.27
Fixed in
  • 9.0.123
  • 10.1.61
  • 11.0.27

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users are strongly recommended to upgrade Apache Tomcat to versions 9.0.123, 10.1.61, or 11.0.27 to resolve this vulnerability.

Description

Apache Tomcat contains a vulnerability in HTTP/2 asynchronous servlet processing where incorrect object recycling and reuse can cause request and response mix-ups between users. This affects versions 9.0.118 through 9.0.122, 10.1.55 through 10.1.60, and 11.0.22 through 11.0.26. The issue is fixed in versions 9.0.123, 10.1.61, and 11.0.27. Users should upgrade to these fixed versions to mitigate the risk.

References

Community reviews

Loading reviews…