Skip to main content
VulnerabilityPublished

CVE-2026-101296: Apache Tomcat · JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms

Affects tomcatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-101296· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 11.0.27 : patch tomcat as a priority.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.27, 10.1.61, 9.0.123
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade tomcat to 11.0.27, 10.1.61 or 9.0.123.

Affected software

ProductAffectedFixed in
Bitnamitomcatpkg:bitnami/tomcatOther threatsAffected
  • >=7.0.0 <9.0.123
  • >=10.1.0 <10.1.61
  • >=11.0.0 <11.0.27
Fixed in
  • 9.0.123
  • 10.1.61
  • 11.0.27

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat instances to versions 11.0.27, 10.1.61, or 9.0.123, where this vulnerability has been fixed. No other mitigation steps are indicated by the vendor advisory.

Description

Apache Tomcat contains an authentication vulnerability in the JNDIRealm when configured with non-GSSAPI SASL mechanisms. This flaw allows attackers to bypass password validation and authenticate without correct credentials. The issue affects multiple versions across Tomcat 7, 8.5, 9, 10.1, and 11 branches. Fixed versions are 11.0.27, 10.1.61, and 9.0.123.

References

Community reviews

Loading reviews…