CVE-2024-51504: Apache ZooKeeper · Authentication bypass with IP-based authentication in Admin Server
Affects zookeeperSource GCVE Database
Not known to be exploited : upgrade to 3.9.3 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.3
Exploitation evidence
Disclosed: evidence found.
CVE published 9 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade zookeeper to 3.9.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamizookeeperpkg:bitnami/zookeeperOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ZooKeeper to version 3.9.3 or later, where this authentication bypass vulnerability is fixed. Until upgrading, consider disabling IP-based authentication or configuring the IPAuthenticationProvider to not trust spoofable HTTP headers like X-Forwarded-For.
Description
Apache ZooKeeper Admin Server using IP-based authentication with the IPAuthenticationProvider is vulnerable to authentication bypass via IP address spoofing. The default configuration relies on the X-Forwarded-For HTTP header to detect client IP addresses, which can be easily spoofed by an attacker. Successful exploitation allows execution of Admin Server commands such as snapshot and restore, potentially leading to information leakage or service disruption. This vulnerability affects ZooKeeper versions from 3.9.0 up to but not including 3.9.3. An official fix is available in version 3.9.3.