Skip to main content
CVE-2006-20001VulnerabilityPublished Updated

Apache2: A carefully crafted If: request header can cause a memory read, or write of a single zero byte, in a pool (heap) memory location beyond the header

Affects apache2Source GCVE Database

0

Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.18-2ubuntu3.17+esm8 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
3.5% chance of exploitation in 30 days – higher than 89% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.18-2ubuntu3.17+esm8, 2.4.29-1ubuntu4.26, 2.4.41-4ubuntu3.13 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jan 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu:Pro:14.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • =2.4.6-2ubuntu2
  • =2.4.6-2ubuntu3
  • =2.4.6-2ubuntu4
  • =2.4.7-1ubuntu1
  • =2.4.7-1ubuntu2
  • =2.4.7-1ubuntu3
  • =2.4.7-1ubuntu4
  • =2.4.7-1ubuntu4.1
  • =2.4.7-1ubuntu4.4
  • =2.4.7-1ubuntu4.5
  • =2.4.7-1ubuntu4.6
  • =2.4.7-1ubuntu4.7
  • =2.4.7-1ubuntu4.8
  • =2.4.7-1ubuntu4.9
  • =2.4.7-1ubuntu4.10
  • =2.4.7-1ubuntu4.11
  • =2.4.7-1ubuntu4.13
  • =2.4.7-1ubuntu4.15
  • =2.4.7-1ubuntu4.16
  • =2.4.7-1ubuntu4.17
  • =2.4.7-1ubuntu4.18
  • =2.4.7-1ubuntu4.19
  • =2.4.7-1ubuntu4.20
  • =2.4.7-1ubuntu4.21
  • =2.4.7-1ubuntu4.22
  • =2.4.7-1ubuntu4.22+esm1
  • =2.4.7-1ubuntu4.22+esm2
  • =2.4.7-1ubuntu4.22+esm3
  • =2.4.7-1ubuntu4.22+esm4
  • =2.4.7-1ubuntu4.22+esm5
  • =2.4.7-1ubuntu4.22+esm6
  • =2.4.7-1ubuntu4.22+esm8
  • =2.4.7-1ubuntu4.22+esm9
  • =2.4.7-1ubuntu4.22+esm10
  • =2.4.7-1ubuntu4.22+esm12
  • =2.4.7-1ubuntu4.22+esm13
  • =2.4.7-1ubuntu4.22+esm14
  • =2.4.7-1ubuntu4.22+esm15
Fixed in–
Ubuntu:Pro:16.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.18-2ubuntu3.17+esm8?arch=source&distro=esm-infra/xenialOther threatsAffected
  • <2.4.18-2ubuntu3.17+esm8
  • =2.4.12-2ubuntu2
  • =2.4.17-1ubuntu1
  • =2.4.17-2ubuntu1
  • =2.4.17-3ubuntu1
  • =2.4.18-1ubuntu1
  • =2.4.18-2ubuntu1
  • =2.4.18-2ubuntu2
  • =2.4.18-2ubuntu3
  • =2.4.18-2ubuntu3.1
  • =2.4.18-2ubuntu3.2
  • =2.4.18-2ubuntu3.3
  • =2.4.18-2ubuntu3.4
  • =2.4.18-2ubuntu3.5
  • =2.4.18-2ubuntu3.7
  • =2.4.18-2ubuntu3.8
  • =2.4.18-2ubuntu3.9
  • =2.4.18-2ubuntu3.10
  • =2.4.18-2ubuntu3.12
  • =2.4.18-2ubuntu3.13
  • =2.4.18-2ubuntu3.14
  • =2.4.18-2ubuntu3.15
  • =2.4.18-2ubuntu3.17
  • =2.4.18-2ubuntu3.17+esm1
  • =2.4.18-2ubuntu3.17+esm2
  • =2.4.18-2ubuntu3.17+esm3
  • =2.4.18-2ubuntu3.17+esm4
  • =2.4.18-2ubuntu3.17+esm5
  • =2.4.18-2ubuntu3.17+esm6
  • =2.4.18-2ubuntu3.17+esm7
Fixed in
  • 2.4.18-2ubuntu3.17+esm8
Ubuntu:18.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.29-1ubuntu4.26?arch=source&distro=bionicOther threatsAffected
  • <2.4.29-1ubuntu4.26
  • =2.4.27-2ubuntu3
  • =2.4.29-1ubuntu1
  • =2.4.29-1ubuntu2
  • =2.4.29-1ubuntu3
  • =2.4.29-1ubuntu4
  • =2.4.29-1ubuntu4.1
  • =2.4.29-1ubuntu4.2
  • =2.4.29-1ubuntu4.3
  • =2.4.29-1ubuntu4.4
  • =2.4.29-1ubuntu4.5
  • =2.4.29-1ubuntu4.6
  • =2.4.29-1ubuntu4.7
  • =2.4.29-1ubuntu4.8
  • =2.4.29-1ubuntu4.10
  • =2.4.29-1ubuntu4.11
  • =2.4.29-1ubuntu4.12
  • =2.4.29-1ubuntu4.13
  • =2.4.29-1ubuntu4.14
  • =2.4.29-1ubuntu4.16
  • =2.4.29-1ubuntu4.17
  • =2.4.29-1ubuntu4.18
  • =2.4.29-1ubuntu4.19
  • =2.4.29-1ubuntu4.20
  • =2.4.29-1ubuntu4.21
  • =2.4.29-1ubuntu4.22
  • =2.4.29-1ubuntu4.23
  • =2.4.29-1ubuntu4.24
  • =2.4.29-1ubuntu4.25
Fixed in
  • 2.4.29-1ubuntu4.26
Ubuntu:20.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.41-4ubuntu3.13?arch=source&distro=focalOther threatsAffected
  • <2.4.41-4ubuntu3.13
  • =2.4.41-1ubuntu1
  • =2.4.41-4ubuntu1
  • =2.4.41-4ubuntu2
  • =2.4.41-4ubuntu3
  • =2.4.41-4ubuntu3.1
  • =2.4.41-4ubuntu3.3
  • =2.4.41-4ubuntu3.4
  • =2.4.41-4ubuntu3.5
  • =2.4.41-4ubuntu3.6
  • =2.4.41-4ubuntu3.7
  • =2.4.41-4ubuntu3.8
  • =2.4.41-4ubuntu3.9
  • =2.4.41-4ubuntu3.10
  • =2.4.41-4ubuntu3.11
  • =2.4.41-4ubuntu3.12
Fixed in
  • 2.4.41-4ubuntu3.13
Ubuntu:22.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.52-1ubuntu4.3?arch=source&distro=jammyOther threatsAffected
  • <2.4.52-1ubuntu4.3
  • =2.4.48-3.1ubuntu3
  • =2.4.48-3.1ubuntu4
  • =2.4.51-2ubuntu1
  • =2.4.52-1ubuntu1
  • =2.4.52-1ubuntu2
  • =2.4.52-1ubuntu4
  • =2.4.52-1ubuntu4.1
  • =2.4.52-1ubuntu4.2
Fixed in
  • 2.4.52-1ubuntu4.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider restricting or filtering suspicious If: headers at perimeter controls if feasible.

Description

A vulnerability in Apache HTTP Server versions 2.4.54 and earlier allows a carefully crafted If: request header to cause a memory read or write of a single zero byte beyond the header value in heap memory. This memory corruption can lead to a process crash. The issue affects multiple specific Ubuntu package versions of Apache 2.4. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…