Skip to main content
CVE-2024-39884VulnerabilityPublished Updated

Apache2: A regression

Affects apache2Source GCVE Database

0

Not known to be exploited · CVSS 6.2 Medium · fixed in 2.4.41-4ubuntu3.19 : update apache2 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.41-4ubuntu3.19, 2.4.52-1ubuntu4.10, 2.4.58-1ubuntu8.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu apache2 to 2.4.41-4ubuntu3.19 (package) or 2.4.52-1ubuntu4.10 (package) or 2.4.58-1ubuntu8.2 (package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.58-1ubuntu8.2?arch=source&distro=nobleOther threatsAffected
  • <2.4.58-1ubuntu8.2
Fixed in
  • 2.4.58-1ubuntu8.2
Ubuntu 22.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.52-1ubuntu4.10?arch=source&distro=jammyOther threatsAffected
  • <2.4.52-1ubuntu4.10
Fixed in
  • 2.4.52-1ubuntu4.10
Ubuntu 20.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.41-4ubuntu3.19?arch=source&distro=focalOther threatsAffected
  • <2.4.41-4ubuntu3.19
Fixed in
  • 2.4.41-4ubuntu3.19
Ubuntu Pro 14.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 2.4.6-2ubuntu2 – 2.4.7-1ubuntu4.22+esm15
38 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache HTTP Server version 2.4.61. Users should upgrade to version 2.4.61 or later to resolve this issue. No other mitigations are indicated by the vendor advisory.

Description

A regression vulnerability in Apache HTTP Server version 2.4.60 causes the server to ignore some legacy content-type based handler configurations such as "AddType". This can lead to source code disclosure of local content, for example, PHP scripts being served as plain text instead of being interpreted. The issue is fixed in Apache HTTP Server version 2.4.61, and users are recommended to upgrade to this version to mitigate the risk.

References

Community reviews

Loading reviews…