Skip to main content
CVE-2019-10098VulnerabilityPublished Updated

Apache2:

Affects apache2Source GCVE Database

0

Public exploit available (Exploit-DB) · 73% EPSS · CVSS 6.1 Medium · fixed in 2.4.18-2ubuntu3.12 : patch apache2 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
73.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.18-2ubuntu3.12, 2.4.29-1ubuntu4.10, 2.4.41-1ubuntu1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 14 Aug 2019

  2. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  3. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE published

    on cve.org

    , t = 0

  2. First Exploit-DB entry (opens in a new tab)

    Apache Httpd mod_rewrite - Open Redirects

    , 61 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu apache2 to 2.4.18-2ubuntu3.12 (package) or 2.4.29-1ubuntu4.10 (package) or 2.4.41-1ubuntu1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 20.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.41-1ubuntu1?arch=source&distro=focalOther threatsAffected
  • <2.4.41-1ubuntu1
Fixed in
  • 2.4.41-1ubuntu1
Ubuntu 18.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.29-1ubuntu4.10?arch=source&distro=bionicOther threatsAffected
  • <2.4.29-1ubuntu4.10
Fixed in
  • 2.4.29-1ubuntu4.10
Ubuntu 16.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.18-2ubuntu3.12?arch=source&distro=xenialOther threatsAffected
  • <2.4.18-2ubuntu3.12
Fixed in
  • 2.4.18-2ubuntu3.12
Ubuntu Pro 14.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 2.4.6-2ubuntu2 – 2.4.7-1ubuntu4.22+esm15
38 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should verify with their operating system or Apache HTTP Server vendor for available updates or patches addressing this issue. Until patched, administrators should review mod_rewrite redirect rules for potential misuse of encoded newline characters and consider implementing additional validation or filtering of URLs.

Description

Apache HTTP Server versions 2.4.0 through 2.4.39 contain a vulnerability in mod_rewrite redirects. Redirects intended to be self-referential can be manipulated using encoded newline characters, causing the server to redirect to an unexpected URL within the request. This behavior may lead to unintended information disclosure or redirect-based attacks. The vulnerability affects multiple Ubuntu-specific Apache 2.4.x package versions. No known exploits are reported in the wild.

References

Community reviews

Loading reviews…