Skip to main content
CVE-2020-1934VulnerabilityPublished Updated

Apache2:

Affects apache2Source GCVE Database

0

Not known to be exploited · 51% EPSS · CVSS 5.3 Medium · fixed in 2.4.18-2ubuntu3.17 : patch apache2 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
51.9% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.18-2ubuntu3.17, 2.4.29-1ubuntu4.14, 2.4.41-4ubuntu3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2020

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu apache2 to 2.4.18-2ubuntu3.17 (package) or 2.4.29-1ubuntu4.14 (package) or 2.4.41-4ubuntu3.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 20.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.41-4ubuntu3.1?arch=source&distro=focalOther threatsAffected
  • <2.4.41-4ubuntu3.1
Fixed in
  • 2.4.41-4ubuntu3.1
Ubuntu 18.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.29-1ubuntu4.14?arch=source&distro=bionicOther threatsAffected
  • <2.4.29-1ubuntu4.14
Fixed in
  • 2.4.29-1ubuntu4.14
Ubuntu 16.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.18-2ubuntu3.17?arch=source&distro=xenialOther threatsAffected
  • <2.4.18-2ubuntu3.17
Fixed in
  • 2.4.18-2ubuntu3.17
Ubuntu Pro 14.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 2.4.6-2ubuntu2 – 2.4.7-1ubuntu4.22+esm15
38 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until patched, avoid proxying to untrusted or malicious FTP servers with mod_proxy_ftp enabled.

Description

Apache HTTP Server versions 2.4.0 through 2.4.41 contain a vulnerability in the mod_proxy_ftp module where uninitialized memory may be used when proxying to a malicious FTP server. This issue could lead to information disclosure but does not affect integrity or availability. The vulnerability affects multiple Ubuntu package versions of Apache 2.4.x. No known exploits are reported in the wild.

References

Community reviews

Loading reviews…