Skip to main content
CVE-2022-36760VulnerabilityPublished Updated

Apache2: Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to

Affects apache2Source GCVE Database

0

Not known to be exploited · CVSS 9.0 High : upgrade to 2.4.18-2ubuntu3.17+esm8 soon.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
9.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.8% chance of exploitation in 30 days – higher than 79% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.18-2ubuntu3.17+esm8, 2.4.29-1ubuntu4.26, 2.4.41-4ubuntu3.13 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jan 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu:Pro:14.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • =2.4.6-2ubuntu2
  • =2.4.6-2ubuntu3
  • =2.4.6-2ubuntu4
  • =2.4.7-1ubuntu1
  • =2.4.7-1ubuntu2
  • =2.4.7-1ubuntu3
  • =2.4.7-1ubuntu4
  • =2.4.7-1ubuntu4.1
  • =2.4.7-1ubuntu4.4
  • =2.4.7-1ubuntu4.5
  • =2.4.7-1ubuntu4.6
  • =2.4.7-1ubuntu4.7
  • =2.4.7-1ubuntu4.8
  • =2.4.7-1ubuntu4.9
  • =2.4.7-1ubuntu4.10
  • =2.4.7-1ubuntu4.11
  • =2.4.7-1ubuntu4.13
  • =2.4.7-1ubuntu4.15
  • =2.4.7-1ubuntu4.16
  • =2.4.7-1ubuntu4.17
  • =2.4.7-1ubuntu4.18
  • =2.4.7-1ubuntu4.19
  • =2.4.7-1ubuntu4.20
  • =2.4.7-1ubuntu4.21
  • =2.4.7-1ubuntu4.22
  • =2.4.7-1ubuntu4.22+esm1
  • =2.4.7-1ubuntu4.22+esm2
  • =2.4.7-1ubuntu4.22+esm3
  • =2.4.7-1ubuntu4.22+esm4
  • =2.4.7-1ubuntu4.22+esm5
  • =2.4.7-1ubuntu4.22+esm6
  • =2.4.7-1ubuntu4.22+esm8
  • =2.4.7-1ubuntu4.22+esm9
  • =2.4.7-1ubuntu4.22+esm10
  • =2.4.7-1ubuntu4.22+esm12
  • =2.4.7-1ubuntu4.22+esm13
  • =2.4.7-1ubuntu4.22+esm14
  • =2.4.7-1ubuntu4.22+esm15
Fixed in–
Ubuntu:Pro:16.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.18-2ubuntu3.17+esm8?arch=source&distro=esm-infra/xenialOther threatsAffected
  • <2.4.18-2ubuntu3.17+esm8
  • =2.4.12-2ubuntu2
  • =2.4.17-1ubuntu1
  • =2.4.17-2ubuntu1
  • =2.4.17-3ubuntu1
  • =2.4.18-1ubuntu1
  • =2.4.18-2ubuntu1
  • =2.4.18-2ubuntu2
  • =2.4.18-2ubuntu3
  • =2.4.18-2ubuntu3.1
  • =2.4.18-2ubuntu3.2
  • =2.4.18-2ubuntu3.3
  • =2.4.18-2ubuntu3.4
  • =2.4.18-2ubuntu3.5
  • =2.4.18-2ubuntu3.7
  • =2.4.18-2ubuntu3.8
  • =2.4.18-2ubuntu3.9
  • =2.4.18-2ubuntu3.10
  • =2.4.18-2ubuntu3.12
  • =2.4.18-2ubuntu3.13
  • =2.4.18-2ubuntu3.14
  • =2.4.18-2ubuntu3.15
  • =2.4.18-2ubuntu3.17
  • =2.4.18-2ubuntu3.17+esm1
  • =2.4.18-2ubuntu3.17+esm2
  • =2.4.18-2ubuntu3.17+esm3
  • =2.4.18-2ubuntu3.17+esm4
  • =2.4.18-2ubuntu3.17+esm5
  • =2.4.18-2ubuntu3.17+esm6
  • =2.4.18-2ubuntu3.17+esm7
Fixed in
  • 2.4.18-2ubuntu3.17+esm8
Ubuntu:18.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.29-1ubuntu4.26?arch=source&distro=bionicOther threatsAffected
  • <2.4.29-1ubuntu4.26
  • =2.4.27-2ubuntu3
  • =2.4.29-1ubuntu1
  • =2.4.29-1ubuntu2
  • =2.4.29-1ubuntu3
  • =2.4.29-1ubuntu4
  • =2.4.29-1ubuntu4.1
  • =2.4.29-1ubuntu4.2
  • =2.4.29-1ubuntu4.3
  • =2.4.29-1ubuntu4.4
  • =2.4.29-1ubuntu4.5
  • =2.4.29-1ubuntu4.6
  • =2.4.29-1ubuntu4.7
  • =2.4.29-1ubuntu4.8
  • =2.4.29-1ubuntu4.10
  • =2.4.29-1ubuntu4.11
  • =2.4.29-1ubuntu4.12
  • =2.4.29-1ubuntu4.13
  • =2.4.29-1ubuntu4.14
  • =2.4.29-1ubuntu4.16
  • =2.4.29-1ubuntu4.17
  • =2.4.29-1ubuntu4.18
  • =2.4.29-1ubuntu4.19
  • =2.4.29-1ubuntu4.20
  • =2.4.29-1ubuntu4.21
  • =2.4.29-1ubuntu4.22
  • =2.4.29-1ubuntu4.23
  • =2.4.29-1ubuntu4.24
  • =2.4.29-1ubuntu4.25
Fixed in
  • 2.4.29-1ubuntu4.26
Ubuntu:20.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.41-4ubuntu3.13?arch=source&distro=focalOther threatsAffected
  • <2.4.41-4ubuntu3.13
  • =2.4.41-1ubuntu1
  • =2.4.41-4ubuntu1
  • =2.4.41-4ubuntu2
  • =2.4.41-4ubuntu3
  • =2.4.41-4ubuntu3.1
  • =2.4.41-4ubuntu3.3
  • =2.4.41-4ubuntu3.4
  • =2.4.41-4ubuntu3.5
  • =2.4.41-4ubuntu3.6
  • =2.4.41-4ubuntu3.7
  • =2.4.41-4ubuntu3.8
  • =2.4.41-4ubuntu3.9
  • =2.4.41-4ubuntu3.10
  • =2.4.41-4ubuntu3.11
  • =2.4.41-4ubuntu3.12
Fixed in
  • 2.4.41-4ubuntu3.13
Ubuntu:22.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.52-1ubuntu4.3?arch=source&distro=jammyOther threatsAffected
  • <2.4.52-1ubuntu4.3
  • =2.4.48-3.1ubuntu3
  • =2.4.48-3.1ubuntu4
  • =2.4.51-2ubuntu1
  • =2.4.52-1ubuntu1
  • =2.4.52-1ubuntu2
  • =2.4.52-1ubuntu4
  • =2.4.52-1ubuntu4.1
  • =2.4.52-1ubuntu4.2
Fixed in
  • 2.4.52-1ubuntu4.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider disabling the mod_proxy_ajp module if not required or applying any recommended configuration changes from the vendor to mitigate request smuggling risks.

Description

An HTTP Request Smuggling vulnerability exists in the mod_proxy_ajp module of Apache HTTP Server versions 2.4.54 and earlier, including multiple specific Ubuntu package versions. This flaw allows an attacker to send crafted HTTP requests that are interpreted inconsistently by the proxy and backend AJP server, potentially enabling request smuggling attacks. No known exploits in the wild have been reported as of the publication date.

References

Community reviews

Loading reviews…