Skip to main content
CVE-2020-11985VulnerabilityPublished Updated

Apache2: IP address spoofing when proxying using mod_remoteip and mod_rewrite For configurations using proxying with mod_remoteip and certain mod_rewrite

Affects apache2Source GCVE Database

0

Not known to be exploited · CVSS 5.3 Low : upgrade to 2.4.18-2ubuntu3.15 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
7.0% chance of exploitation in 30 days – higher than 94% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.18-2ubuntu3.15
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2020

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade apache2 to 2.4.18-2ubuntu3.15.

Affected software

ProductAffectedFixed in
Ubuntu:Pro:14.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • =2.4.6-2ubuntu2
  • =2.4.6-2ubuntu3
  • =2.4.6-2ubuntu4
  • =2.4.7-1ubuntu1
  • =2.4.7-1ubuntu2
  • =2.4.7-1ubuntu3
  • =2.4.7-1ubuntu4
  • =2.4.7-1ubuntu4.1
  • =2.4.7-1ubuntu4.4
  • =2.4.7-1ubuntu4.5
  • =2.4.7-1ubuntu4.6
  • =2.4.7-1ubuntu4.7
  • =2.4.7-1ubuntu4.8
  • =2.4.7-1ubuntu4.9
  • =2.4.7-1ubuntu4.10
  • =2.4.7-1ubuntu4.11
  • =2.4.7-1ubuntu4.13
  • =2.4.7-1ubuntu4.15
  • =2.4.7-1ubuntu4.16
  • =2.4.7-1ubuntu4.17
  • =2.4.7-1ubuntu4.18
  • =2.4.7-1ubuntu4.19
  • =2.4.7-1ubuntu4.20
  • =2.4.7-1ubuntu4.21
  • =2.4.7-1ubuntu4.22
  • =2.4.7-1ubuntu4.22+esm1
  • =2.4.7-1ubuntu4.22+esm2
  • =2.4.7-1ubuntu4.22+esm3
  • =2.4.7-1ubuntu4.22+esm4
  • =2.4.7-1ubuntu4.22+esm5
  • =2.4.7-1ubuntu4.22+esm6
  • =2.4.7-1ubuntu4.22+esm8
  • =2.4.7-1ubuntu4.22+esm9
  • =2.4.7-1ubuntu4.22+esm10
  • =2.4.7-1ubuntu4.22+esm12
  • =2.4.7-1ubuntu4.22+esm13
  • =2.4.7-1ubuntu4.22+esm14
  • =2.4.7-1ubuntu4.22+esm15
Fixed in–
Ubuntu:16.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.18-2ubuntu3.15?arch=source&distro=xenialOther threatsAffected
  • <2.4.18-2ubuntu3.15
  • =2.4.12-2ubuntu2
  • =2.4.17-1ubuntu1
  • =2.4.17-2ubuntu1
  • =2.4.17-3ubuntu1
  • =2.4.18-1ubuntu1
  • =2.4.18-2ubuntu1
  • =2.4.18-2ubuntu2
  • =2.4.18-2ubuntu3
  • =2.4.18-2ubuntu3.1
  • =2.4.18-2ubuntu3.2
  • =2.4.18-2ubuntu3.3
  • =2.4.18-2ubuntu3.4
  • =2.4.18-2ubuntu3.5
  • =2.4.18-2ubuntu3.7
  • =2.4.18-2ubuntu3.8
  • =2.4.18-2ubuntu3.9
  • =2.4.18-2ubuntu3.10
  • =2.4.18-2ubuntu3.12
  • =2.4.18-2ubuntu3.13
  • =2.4.18-2ubuntu3.14
Fixed in
  • 2.4.18-2ubuntu3.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache HTTP Server version 2.4.24. Users should upgrade to version 2.4.24 or later to remediate this vulnerability. No other specific mitigations are indicated.

Description

A vulnerability in Apache HTTP Server allows IP address spoofing when proxying using mod_remoteip combined with certain mod_rewrite rules. This can cause an attacker to spoof their IP address in logs and PHP scripts. The issue was fixed in Apache HTTP Server version 2.4.24 and was assigned a low severity CVE in 2020.

References

Community reviews

Loading reviews…