Skip to main content
CVE-2022-37436VulnerabilityPublished Updated

Apache2: Prior to Apache HTTP Server 2.4.55, a malicious backend can cause the response headers to be truncated early, resulting in some headers being

Affects apache2Source GCVE Database

0

Not known to be exploited · 55% EPSS · CVSS 5.3 Medium : upgrade to 2.4.18-2ubuntu3.17+esm9 as a priority.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
55.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.18-2ubuntu3.17+esm9, 2.4.29-1ubuntu4.26, 2.4.41-4ubuntu3.13 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jan 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu:Pro:14.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • =2.4.6-2ubuntu2
  • =2.4.6-2ubuntu3
  • =2.4.6-2ubuntu4
  • =2.4.7-1ubuntu1
  • =2.4.7-1ubuntu2
  • =2.4.7-1ubuntu3
  • =2.4.7-1ubuntu4
  • =2.4.7-1ubuntu4.1
  • =2.4.7-1ubuntu4.4
  • =2.4.7-1ubuntu4.5
  • =2.4.7-1ubuntu4.6
  • =2.4.7-1ubuntu4.7
  • =2.4.7-1ubuntu4.8
  • =2.4.7-1ubuntu4.9
  • =2.4.7-1ubuntu4.10
  • =2.4.7-1ubuntu4.11
  • =2.4.7-1ubuntu4.13
  • =2.4.7-1ubuntu4.15
  • =2.4.7-1ubuntu4.16
  • =2.4.7-1ubuntu4.17
  • =2.4.7-1ubuntu4.18
  • =2.4.7-1ubuntu4.19
  • =2.4.7-1ubuntu4.20
  • =2.4.7-1ubuntu4.21
  • =2.4.7-1ubuntu4.22
  • =2.4.7-1ubuntu4.22+esm1
  • =2.4.7-1ubuntu4.22+esm2
  • =2.4.7-1ubuntu4.22+esm3
  • =2.4.7-1ubuntu4.22+esm4
  • =2.4.7-1ubuntu4.22+esm5
  • =2.4.7-1ubuntu4.22+esm6
  • =2.4.7-1ubuntu4.22+esm8
  • =2.4.7-1ubuntu4.22+esm9
  • =2.4.7-1ubuntu4.22+esm10
  • =2.4.7-1ubuntu4.22+esm12
  • =2.4.7-1ubuntu4.22+esm13
  • =2.4.7-1ubuntu4.22+esm14
  • =2.4.7-1ubuntu4.22+esm15
Fixed in–
Ubuntu:Pro:16.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.18-2ubuntu3.17+esm9?arch=source&distro=esm-infra/xenialOther threatsAffected
  • <2.4.18-2ubuntu3.17+esm9
  • =2.4.12-2ubuntu2
  • =2.4.17-1ubuntu1
  • =2.4.17-2ubuntu1
  • =2.4.17-3ubuntu1
  • =2.4.18-1ubuntu1
  • =2.4.18-2ubuntu1
  • =2.4.18-2ubuntu2
  • =2.4.18-2ubuntu3
  • =2.4.18-2ubuntu3.1
  • =2.4.18-2ubuntu3.2
  • =2.4.18-2ubuntu3.3
  • =2.4.18-2ubuntu3.4
  • =2.4.18-2ubuntu3.5
  • =2.4.18-2ubuntu3.7
  • =2.4.18-2ubuntu3.8
  • =2.4.18-2ubuntu3.9
  • =2.4.18-2ubuntu3.10
  • =2.4.18-2ubuntu3.12
  • =2.4.18-2ubuntu3.13
  • =2.4.18-2ubuntu3.14
  • =2.4.18-2ubuntu3.15
  • =2.4.18-2ubuntu3.17
  • =2.4.18-2ubuntu3.17+esm1
  • =2.4.18-2ubuntu3.17+esm2
  • =2.4.18-2ubuntu3.17+esm3
  • =2.4.18-2ubuntu3.17+esm4
  • =2.4.18-2ubuntu3.17+esm5
  • =2.4.18-2ubuntu3.17+esm6
  • =2.4.18-2ubuntu3.17+esm7
  • =2.4.18-2ubuntu3.17+esm8
Fixed in
  • 2.4.18-2ubuntu3.17+esm9
Ubuntu:18.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.29-1ubuntu4.26?arch=source&distro=bionicOther threatsAffected
  • <2.4.29-1ubuntu4.26
  • =2.4.27-2ubuntu3
  • =2.4.29-1ubuntu1
  • =2.4.29-1ubuntu2
  • =2.4.29-1ubuntu3
  • =2.4.29-1ubuntu4
  • =2.4.29-1ubuntu4.1
  • =2.4.29-1ubuntu4.2
  • =2.4.29-1ubuntu4.3
  • =2.4.29-1ubuntu4.4
  • =2.4.29-1ubuntu4.5
  • =2.4.29-1ubuntu4.6
  • =2.4.29-1ubuntu4.7
  • =2.4.29-1ubuntu4.8
  • =2.4.29-1ubuntu4.10
  • =2.4.29-1ubuntu4.11
  • =2.4.29-1ubuntu4.12
  • =2.4.29-1ubuntu4.13
  • =2.4.29-1ubuntu4.14
  • =2.4.29-1ubuntu4.16
  • =2.4.29-1ubuntu4.17
  • =2.4.29-1ubuntu4.18
  • =2.4.29-1ubuntu4.19
  • =2.4.29-1ubuntu4.20
  • =2.4.29-1ubuntu4.21
  • =2.4.29-1ubuntu4.22
  • =2.4.29-1ubuntu4.23
  • =2.4.29-1ubuntu4.24
  • =2.4.29-1ubuntu4.25
Fixed in
  • 2.4.29-1ubuntu4.26
Ubuntu:20.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.41-4ubuntu3.13?arch=source&distro=focalOther threatsAffected
  • <2.4.41-4ubuntu3.13
  • =2.4.41-1ubuntu1
  • =2.4.41-4ubuntu1
  • =2.4.41-4ubuntu2
  • =2.4.41-4ubuntu3
  • =2.4.41-4ubuntu3.1
  • =2.4.41-4ubuntu3.3
  • =2.4.41-4ubuntu3.4
  • =2.4.41-4ubuntu3.5
  • =2.4.41-4ubuntu3.6
  • =2.4.41-4ubuntu3.7
  • =2.4.41-4ubuntu3.8
  • =2.4.41-4ubuntu3.9
  • =2.4.41-4ubuntu3.10
  • =2.4.41-4ubuntu3.11
  • =2.4.41-4ubuntu3.12
Fixed in
  • 2.4.41-4ubuntu3.13
Ubuntu:22.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.52-1ubuntu4.3?arch=source&distro=jammyOther threatsAffected
  • <2.4.52-1ubuntu4.3
  • =2.4.48-3.1ubuntu3
  • =2.4.48-3.1ubuntu4
  • =2.4.51-2ubuntu1
  • =2.4.52-1ubuntu1
  • =2.4.52-1ubuntu2
  • =2.4.52-1ubuntu4
  • =2.4.52-1ubuntu4.1
  • =2.4.52-1ubuntu4.2
Fixed in
  • 2.4.52-1ubuntu4.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache HTTP Server version 2.4.55. Users should upgrade to version 2.4.55 or later to remediate this issue. Patch status is confirmed by the version cutoff. Until upgraded, administrators should be aware of the risk posed by malicious backends manipulating response headers.

Description

Prior to Apache HTTP Server 2.4.55, a vulnerability exists where a malicious backend can cause response headers to be truncated early. This truncation results in some headers being included in the response body rather than being processed as headers. Consequently, security-related headers may not be interpreted by the client, potentially weakening security controls.

References

Community reviews

Loading reviews…