Apache2: Some mod_proxy configurations on Apache HTTP Server versions 2.4.0 through 2.4.55 allow a HTTP Request Smuggling attack
Affects apache2Source GCVE Database
Not known to be exploited · 84% EPSS · CVSS 9.8 Critical · fixed in 2.4.18-2ubuntu3.17+esm10 : patch apache2 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 84.5% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.18-2ubuntu3.17+esm10, 2.4.29-1ubuntu4.27, 2.4.41-4ubuntu3.14 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Mar 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 22.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.52-1ubuntu4.4?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu 20.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.41-4ubuntu3.14?arch=source&distro=focalOther threats | Affected
| Fixed in
|
Ubuntu 18.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.29-1ubuntu4.27?arch=source&distro=bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.18-2ubuntu3.17+esm10?arch=source&distro=esm-infra/xenialOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Apache HTTP Server version 2.4.56 and later. Users should upgrade to version 2.4.56 or newer to mitigate this vulnerability.
Description
Certain mod_proxy configurations in Apache HTTP Server versions 2.4.0 through 2.4.55 allow HTTP Request Smuggling attacks when mod_proxy is enabled with RewriteRule or ProxyPassMatch directives using non-specific URL rewrite patterns. This vulnerability can lead to bypassing access controls, proxying unintended URLs, and cache poisoning. Upgrading to Apache HTTP Server version 2.4.56 or later mitigates this issue.