Skip to main content
VulnerabilityPublished Updated

CVE-2026-48913: Apache2 · Use After Free vulnerability in Apache HTTP Server module mod_http2 when file handles are already exhausted

Affects apache2Source GCVE Database

0
Compare
Authoritative record:CVE-2026-48913· High 7.3

Not known to be exploited · CVSS 7.3 High · fixed in 2.4.41-4ubuntu3.23+esm5 : patch apache2 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.41-4ubuntu3.23+esm5, 2.4.52-1ubuntu4.23, 2.4.58-1ubuntu8.15 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=resoluteOther threatsAffected
  • <2.4.66-2ubuntu2.4
Fixed in
  • 2.4.66-2ubuntu2.4
Ubuntu 25.10apache2pkg:deb/ubuntu/apache2?arch=source&distro=questingOther threatsAffected
  • 2.4.63-1ubuntu1 – 2.4.64-1ubuntu3.5
8 affected builds
Fixed in–
Ubuntu 24.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=nobleOther threatsAffected
  • <2.4.58-1ubuntu8.15
Fixed in
  • 2.4.58-1ubuntu8.15
Ubuntu 22.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=jammyOther threatsAffected
  • <2.4.52-1ubuntu4.23
Fixed in
  • 2.4.52-1ubuntu4.23
Ubuntu Pro 20.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=esm-infra/focalOther threatsAffected
  • <2.4.41-4ubuntu3.23+esm5
Fixed in
  • 2.4.41-4ubuntu3.23+esm5
Ubuntu Pro 18.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 2.4.27-2ubuntu3 – 2.4.29-1ubuntu4.27+esm13
42 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should apply the official updates from their vendor or distribution to remediate the issue. Since the vendor advisory confirms patch availability, deploying the update is the recommended mitigation.

Description

A Use After Free vulnerability exists in the Apache HTTP Server module mod_http2 when file handles are exhausted. This affects Apache HTTP Server versions from 2.4.55 through 2.4.67 and can impact confidentiality, integrity, and availability. No known exploits are reported in the wild. Patch status is confirmed as available but not detailed in the provided data.

References

Community reviews

Loading reviews…