Skip to main content
VulnerabilityPublished

CVE-2026-49146: App::Ack versions before 3.10.0 for Perl allow memory exhaustion via an unbounded context value in a

Affects ackSource GCVE Database

0
Authoritative record:CVE-2026-49146· High 7.5

Not known to be exploited · CVSS 7.5 High.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10ackpkg:deb/ubuntu/ack?arch=source&distro=stonkingOther threatsAffected
  • =3.8.1-1
Fixed in–
Ubuntu 26.04 LTSackpkg:deb/ubuntu/ack?arch=source&distro=resoluteOther threatsAffected
  • =3.8.1-1
Fixed in–
Ubuntu 25.10ackpkg:deb/ubuntu/ack?arch=source&distro=questingOther threatsAffected
  • =3.7.0-1
  • =3.8.1-1
Fixed in–
Ubuntu 24.04 LTSackpkg:deb/ubuntu/ack?arch=source&distro=nobleOther threatsAffected
  • =3.7.0-1
Fixed in–
Ubuntu 22.04 LTSackpkg:deb/ubuntu/ack?arch=source&distro=jammyOther threatsAffected
  • =3.4.0-1
  • =3.5.0-1
Fixed in–
Ubuntu 20.04 LTSackpkg:deb/ubuntu/ack?arch=source&distro=focalOther threatsAffected
  • 3.0.2-1 – 3.3.1-1
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to App::Ack version 3.10.0 or later where this vulnerability is fixed. No vendor advisory or patch links are provided, but the description indicates versions before 3.10.0 are affected, implying the fix is in 3.10.0. Until upgrade, avoid using untrusted .ackrc files or context values.

Description

App::Ack versions before 3.10.0 for Perl have a vulnerability where a maliciously large context value in a project .ackrc file can cause excessive memory allocation. This leads to memory exhaustion and process termination.

References

Community reviews

Loading reviews…