CVE-2026-84967: Arbitrary command execution via shell-expanded connection string in Launch MongoDB Shell terminal
Affects mongodbSource GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.17.1 when convenient.
Data as of 27 Oct 2026, 05:11 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.17.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade mongodb to 1.17.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimongodbpkg:bitnami/mongodbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability; users should upgrade the MongoDB extension for Visual Studio Code to version 1.17.1 or later. Until patched, developers should avoid accepting untrusted connection strings and refrain from opening the shell feature with user-supplied connection targets. The vendor advisory should be consulted for the official fix and update instructions.
Description
A vulnerability in the MongoDB extension for Visual Studio Code allows an unauthenticated remote attacker to execute arbitrary commands via a specially crafted connection string. The extension fails to neutralize special characters in the connection string before embedding it into a shell command line for the integrated terminal. Exploitation requires user interaction, including accepting a user-supplied connection target and opening the shell feature. The confirmation prompt does not reveal the malicious input. This issue affects versions from 1.13.0 up to but not including 1.17.1. A patch is available to address this vulnerability.