ArcadeDB before 26.10.2 contains an improper authorization vulnerability that allows revoked users to retain access through already-open Postgres, Bolt, MongoDB, or Redis wire-protocol connections
Source GCVE Database
Not known to be exploited · CVSS 7.6 High : upgrade to 26.10.2 soon.
Data as of 30 Oct 2026, 16:33 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.6 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.8 |
- Patch
- Available – fixed in 26.10.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade arcadedb to 26.10.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ArcadeDataarcadedb | Affected
| Fixed in
|
Mavenarcadedbpkg:maven/arcadedbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
ArcadeDB before 26.10.2 contains an improper authorization vulnerability that allows revoked users to retain access through already-open Postgres, Bolt, MongoDB, or Redis wire-protocol connections. Attackers holding an existing connection can keep reading and writing data after deletion, grant removal, or password rotation, because executors keep a stale ServerSecurityUser.