Skip to main content
VulnerabilityPublished Updated

CVE-2026-42497: Archive::Tar versions before 3.08 for Perl extract hardlinks to attacker controlled paths outside the

Affects perlSource GCVE Database

0
Compare
Authoritative record:CVE-2026-42497· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.38.2-3.2ubuntu0.3 soon.

Data as of 6 Nov 2026, 15:38 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.38.2-3.2ubuntu0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the Ubuntu perl package to 5.38.2-3.2ubuntu0.3.

Affected software

ProductAffectedFixed in
Ubuntu 26.10perlpkg:deb/ubuntu/perl?arch=source&distro=stonkingOther threatsAffected
  • 5.40.1-7build1 – 5.42.3-1
4 affected builds
Fixed in–
Ubuntu 25.10perlpkg:deb/ubuntu/perl?arch=source&distro=questingOther threatsAffected
  • 5.40.1-2 – 5.40.1-6ubuntu0.1
6 affected builds
Fixed in–
Ubuntu 24.04 LTSperlpkg:deb/ubuntu/perl?arch=source&distro=nobleOther threatsAffected
  • <5.38.2-3.2ubuntu0.3
Fixed in
  • 5.38.2-3.2ubuntu0.3
Ubuntu 22.04 LTSperlpkg:deb/ubuntu/perl?arch=source&distro=jammyOther threatsAffected
  • 5.32.1-3ubuntu3 – 5.34.0-3ubuntu1.9
10 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSperlpkg:deb/ubuntu/perl?arch=source&distro=esm-infra/focalOther threatsAffected
  • 5.28.1-6build1 – 5.30.0-9ubuntu0.5+esm4
11 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSperlpkg:deb/ubuntu/perl?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 5.26.0-8ubuntu1 – 5.26.1-6ubuntu0.7+esm4
16 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Archive::Tar version 3.08 and later. Users should upgrade to version 3.08 or apply the fixed version 5.38.2-3.2ubuntu0.3 or later in their distributions. Until patched, avoid extracting untrusted tar archives with vulnerable versions of Archive::Tar. No other vendor advisory states that the issue is already mitigated or requires no action.

Description

Archive::Tar versions before 3.08 for Perl contain a vulnerability where hardlinks in tar archives can be extracted to attacker-controlled paths outside the intended extraction directory. This occurs because the function handling special files does not validate the linkname against absolute paths or directory traversal sequences, allowing an attacker to create a hardlink that shares an inode with a victim file. Subsequent writes to the extracted file modify the victim file, and file metadata changes are applied to the shared inode during extraction.

References

Community reviews

Loading reviews…