Skip to main content
VulnerabilityPublished Updated

CVE-2024-4577: PHP-CGI · Argument Injection

Affects phpSource GCVE Database

0
Authoritative record:CVE-2024-4577· Critical 9.8

Exploited in the wild · used in ransomware campaigns · KEV due 3 Jul 2024 · public exploit available (Metasploit, Exploit-DB) · 99% EPSS · fixed in 8.3.8 : patch php now.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else.
Ransomware
Used in ransomware campaigns
EPSS
99.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.8, 8.2.20, 8.1.29
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 9 Jun 2024

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 3 days after disclosure

  3. Observed by OffSeq Mirage: evidence found.

    185 honeypot hits, first 2.4 years after disclosure

Timeline

  1. CVE ID reserved

    by PHP Group

    , 34 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. Added to CISA KEV (opens in a new tab)

    exploitation confirmed · ransomware use known

    , 3 days after disclosure

  4. KEV remediation due

    US federal deadline

    , 24 days after disclosure

  5. First Exploit-DB entry (opens in a new tab)

    PHP CGI Module 8.3.4 - Remote Code Execution (RCE)

    , 1 year after disclosure

  6. First seen by OffSeq Mirage

    from 33 attacker networks; activity in United States, Germany, Netherlands, United Kingdom and 3 more

    , 2.4 years after disclosure

  7. , 2.4 years after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade php to 8.3.8, 8.2.20 or 8.1.29.

Affected software

ProductAffectedFixed in
Bitnamiphppkg:bitnami/phpOther threatsAffected
  • <8.1.29
  • >=8.2.0 <8.2.20
  • >=8.3.0 <8.3.8
Fixed in
  • 8.1.29
  • 8.2.20
  • 8.3.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A critical vulnerability (CVE-2024-4577) affects PHP-CGI on Windows when used with Apache and certain code pages. In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, and 8.3.* before 8.3.8, Windows may apply "Best-Fit" character replacement in command-line arguments, causing PHP-CGI to misinterpret these as PHP options. This can allow attackers to pass malicious options to the PHP binary, potentially exposing source code or enabling arbitrary code execution.

References

Community reviews

Loading reviews…