Skip to main content
CVE-2026-6527VulnerabilityPublished

Wireshark · ASN.1 PER protocol dissector crash

Source GCVE Database

0
Authoritative record:CVE-2026-6527· Medium 5.5

Not known to be exploited · CVSS 5.5 Medium : upgrade to 4.6.5 or 4.4.15 when convenient.

Data as of 27 Oct 2026, 00:19 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.5, 4.4.15
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Wireshark to 4.6.5 or 4.4.15.

Affected software

ProductAffectedFixed in
Wireshark FoundationWiresharkAffected
  • >=4.6.0 <4.6.5
Fixed in
  • 4.6.5
Wireshark FoundationWiresharkAffected
  • >=4.4.0 <4.4.15
Fixed in
  • 4.4.15
GitHubwireshark/wiresharkpkg:github/wireshark/wiresharkOther threatsAffected
  • =4.6.0
  • =4.4.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid opening untrusted ASN.1 PER protocol packets in affected Wireshark versions.

Description

A vulnerability in Wireshark versions 4.4.0 to 4.4.14 and 4.6.0 to 4.6.4 allows a denial of service due to a crash in the ASN.1 PER protocol dissector. This flaw can be triggered by processing crafted packets, causing the application to crash and disrupt service.

References

Community reviews

Loading reviews…