Skip to main content
VulnerabilityPublished Updated

CVE-2024-6678: GitLab · Authentication Bypass by Spoofing

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.3.2 : patch gitlab as a priority.

Data as of 26 Oct 2026, 09:08 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.9% chance of exploitation in 30 days – higher than 80% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.3.2, 17.2.5, 17.1.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.3.2, 17.2.5 or 17.1.7.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=8.14.0 <17.1.7
  • >=17.2.0 <17.2.5
  • >=17.3.0 <17.3.2
Fixed in
  • 17.1.7
  • 17.2.5
  • 17.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to GitLab versions 17.1.7 or later, 17.2.5 or later, or 17.3.2 or later to remediate this issue. Applying the official fixes from the vendor is the recommended mitigation.

Description

A critical authentication bypass vulnerability (CVE-2024-6678) exists in GitLab CE/EE that affects multiple version ranges. This flaw allows an attacker to trigger a pipeline as an arbitrary user under certain conditions. The issue impacts versions from 8.14 up to but not including 17.1.7, from 17.2 up to but not including 17.2.5, and from 17.3 up to but not including 17.3.2. A patch is available to remediate this vulnerability.

References

Community reviews

Loading reviews…