Skip to main content
VulnerabilityPublished Updated

CVE-2026-28498: Authlib · Fail-Open Cryptographic Verification in OIDC Hash Binding

Affects mcpmSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 2.13.0_3 soon.

Data as of 30 Oct 2026, 07:14 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.13.0_3
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mcpm to 2.13.0_3.

Affected software

ProductAffectedFixed in
Homebrewmcpmpkg:brew/mcpmOther threatsAffected
  • >=2.1.0 <2.13.0_3
Fixed in
  • 2.13.0_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Authlib version 2.13.0_3 that corrects the fail-open behavior by enforcing fail-closed validation for unsupported algorithms. Users should upgrade to version 2.13.0_3 or later to remediate this vulnerability. Until patched, there is no reliable workaround at the application level because the flaw is within the library's core validation logic. Implementers must ensure they use the fixed version to maintain compliance with OIDC and JWT security requirements.

Description

A critical vulnerability in the Authlib Python library's OpenID Connect (OIDC) ID Token validation allows bypassing integrity checks for Access Token and Authorization Code hashes. The flaw causes the library to incorrectly accept tokens with unsupported cryptographic algorithms by returning a successful validation result instead of failing. This fail-open behavior violates OIDC and JWT specifications, enabling attackers to substitute tokens without detection. The issue affects Authlib versions from 2.1.0 up to but not including 2.13.0_3. A patch is available in version 2.13.0_3 that enforces fail-closed behavior on unsupported algorithms.

References

Community reviews

Loading reviews…