CVE-2024-37568: Authlib has algorithm confusion with asymmetric public keys
Affects authlibSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 1.3.1 soon.
Data as of 29 Oct 2026, 23:51 UTC
- Patch
- Available – fixed in 1.3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade authlib to 1.3.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIauthlib | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Authlib version 1.3.1 that fixes this algorithm confusion vulnerability. Users should upgrade to version 1.3.1 or later to remediate this issue. Until upgraded, explicitly specifying the algorithm parameter in jwt.decode calls may reduce risk, but upgrading is the recommended solution.
Description
Authlib versions before 1.3.1 suffer from an algorithm confusion vulnerability involving asymmetric public keys. When decoding JWTs without specifying an algorithm, the library incorrectly allows HMAC verification using any asymmetric public key. This flaw can lead to improper verification of tokens, potentially enabling attackers to bypass authentication controls.
References
- nvd.nist.gov/vuln/detail/CVE-2024-37568 (opens in a new tab)
- github.com/lepture/authlib/issues/654 (opens in a new tab)
- github.com/lepture/authlib (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/authlib/PYSEC-2024-52.yaml (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/10/msg00032.html (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FHJI32SN4FNAUVNALVGOKWHNSQ6XS3M5 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IZI7HYGN7VZAYFV6UV3SRLYF7QGERXIU (opens in a new tab)
- vicarius.io/vsociety/posts/algorithm-confusion-in-lepture-authlib-cve-2024-37568 (opens in a new tab)