CVE-2024-5258: GitLab · Insecure Direct Object Reference
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 17.0.1 : update gitlab when convenient.
Data as of 26 Oct 2026, 08:30 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.0.1, 16.11.3, 16.10.6
Exploitation evidence
Disclosed: evidence found.
CVE published 29 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.0.1, 16.11.3 or 16.10.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading GitLab to versions 16.10.6, 16.11.3, or 17.0.1 or later. Applying these official fixes will remediate the authorization bypass vulnerability.
Description
GitLab versions 16.10 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1 contain an authorization vulnerability. An authenticated attacker could exploit a crafted naming convention to bypass pipeline authorization logic. This issue allows unauthorized pipeline actions by manipulating user-controlled keys. The vulnerability has been patched in the specified fixed versions.