CVE-2024-55500: Avenwu Whistle Cross-Site Request Forgery (CSRF)
Affects whistleSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2.10.8 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade whistle to 2.10.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewwhistlepkg:brew/whistleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the vulnerability is fixed in Avenwu Whistle version 2.10.8. Users and administrators should upgrade to version 2.10.8 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.
Description
Avenwu Whistle versions 2.9.90 and earlier are vulnerable to a Cross-Site Request Forgery (CSRF) vulnerability that allows attackers to perform malicious API calls. This can lead to the execution of arbitrary code on the victim's machine. The vulnerability is fixed in version 2.10.8.