CVE-2026-119197: Awscli@1 · pyasn1 has quadratic-complexity denial of service in binary REAL decoding
Affects awscli@1Source GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 0.6.5 : patch awscli@1 soon.
Data as of 31 Oct 2026, 16:22 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 0.6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewawscli@1pkg:brew/awscli%401Other threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade pyasn1 to version 0.6.5 or later, where the decoding inefficiency is fixed. Until upgrading, applications should reject or strictly limit ASN.1 input containing REAL values, especially those with large mantissas, before passing data to pyasn1 decoders. The fix in 0.6.5 addresses the issue for BER, CER, and DER decoders. No other mitigations are specifically recommended.
Description
CVE-2026-119197 is a denial of service vulnerability in pyasn1 versions 0.6.4 and earlier, affecting the decoding of binary ASN.1 REAL values with large mantissas. The decoding process has quadratic time complexity due to inefficient byte processing, causing excessive CPU consumption. This impacts BER, CER, and DER decoders using the vulnerable RealPayloadDecoder. The vulnerability can be triggered when an application decodes attacker-controlled ASN.1 data containing REAL values. The issue was fixed in pyasn1 version 0.6.5 by optimizing the decoding loop.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-mm57-4v3p-rchx (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119197 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/ce3ec3390784780a530047e0e77be5ff457636a4 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)