Skip to main content
CVE-2026-21531VulnerabilityPublished Updated

Azure ai language conversations authoring: Azure AI Language Authoring Elevation of Privilege Vulnerability can Lead

Affects azure-ai-language-conversations-authoringSource GCVE Database

0
Authoritative record:CVE-2026-21531· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.0.0b4 as a priority.

Data as of 27 Oct 2026, 17:57 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.5% chance of exploitation in 30 days – higher than 85% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.0b4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade azure-ai-language-conversations-authoring to 1.0.0b4.

Affected software

ProductAffectedFixed in
PyPIazure-ai-language-conversations-authoringAffected
  • <1.0.0b4
Fixed in
  • 1.0.0b4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to version 1.0.0b4 or later of the Azure AI Language Conversations Authoring Python client library to remediate this vulnerability. Since a patch is available, applying the official fix is the recommended mitigation.

Description

A critical deserialization vulnerability exists in the Azure AI Language Conversations Authoring client library for Python prior to version 1.0.0b4. This flaw allows an unauthorized attacker to execute arbitrary code remotely by sending crafted data to the affected library. The vulnerability is identified as CVE-2026-21531 and has a CVSS score of 9.8, indicating a high severity with network attack vector and no required privileges or user interaction.

References

Community reviews

Loading reviews…